td4 2005 not firing up!!!

This site contains affiliate links for which LandyZone may be compensated if you make a purchase.

steve569

Member
Posts
26
Location
haxey north lincs
just replaced the following
main fuel injection pump(recon)
fuel pressure sensor and wires (garage)
low pressure pump (garage)
cam sensor
engine temp sensor
basically garage did service , diagnostics and changed a few things to get it running ,it sat at the garage waiting for them to fit the main fuel pump, they obviously didnt want to do it, so done it myself
I have fuel to the injectors
no fault codes
turning over
not firing up
fuel in tank
help
 
Hi,

Erase the codes, then read them again.
Do you have rpm readings, hp pump presure and low fuel presure when cranking ?
 
had RAC come and do diagnostics, cleared them and came back with open circuits in fuel cables
cleaned all sensors, electrolube used on connectors, now got a faulty speed sensor showing, no other faults, still not firing up
biggest bag of crap wife ever bought !!!!
 
Hi,

Do you have rpm readings, hp pump pressure and low fuel pressure when cranking ?
You should get an reader that can read all the values for the car.

To start you should have :
- at least 450~500 rpm
- at least 6000 kpa for the hp fuel pump when cranking.
- no fuel leak.
- a good battery ( at least 12v )
- a good injectors ( small return flow )
- a working cam sensor.
- a working crank sensor ( gives the rpm reading ).
- a working rail presure sensor ( should give at least 1v or a code when not working ).

So the injectors need to be tested ( fuel leak-back test ).

The TD4 engine won't break easily, but all the accessory that makes it run, like Injectors and hp fuel pump are pretty common to fail.
 
had RAC come and do diagnostics, cleared them and came back with open circuits in fuel cables
cleaned all sensors, electrolube used on connectors, now got a faulty speed sensor showing, no other faults, still not firing up
biggest bag of crap wife ever bought !!!!
It's a BMW engine, so comes with BMW reliability. Actually they're normally pretty good.
Speed sensor code is related to the crank sensor.
 
my code reader unable to show rpms
have deleted all codes, now zero codes showing
its a brand new crank sensor,just cleaned connectors
got good compression, fuel to injectors comes out at pressure
just not firing up
ready to set fire to it to be honest
 
When you say it don't fire, what does that mean ?
The engine is turning, and start vibrating like it going to start ? Or does the engine stays still ?

Your code reader should show rpms when cranking, even a basic one can do.

Try to get an icarsoft tool first, changing parts will not help to spot an issue.

It's impossible to spot a bad hp pump, low pressure pump without diag tools.
Where did you get the hp fuel pump, if it is an used one that has come not tested ... certainly a faulty one.

Also you can't start if one or more injectors are bad. Fuel return test can spot a bad one.

The last thing to check, is the cylinders compression ...
 
Last edited:
When you say it don't fire, what does that mean ?
The engine is turning, and start vibrating like it going to start ? Or does the engine stays still ?

Your code reader should show rpms when cranking, even a basic one can do.

Try to get an icarsoft tool first, changing parts will not help to spot an issue.

It's impossible to stop a bad hp pump, low pressure pump without diag tools.
Where did you get the hp fuel pump, if it is an used one that has come not tested ... certainly a faulty one.

Also you can't start if one or more injectors are bad. Fuel return test can spot a bad one.

The last thing to check, is the cylinders compression ...
have an icarsoft tool that has gone tits up,the pump is a recon bosche pump
have a replacement icarsoft en route
much prefer the old landrovers with carbs, spark plugs, distributors, instead of all these sensor s on everything:-(
 
Hi,

Injectors have electronics on them. If only one injector is not openning the engine will not start.

The management system for the direct injection in the freelander is very simple.
Most of the electronics are only here to prevent to break somerhing in the system. The hp pump or an injector will not survive if it is running dry.

Best is the check injectors fuel test :

XiTuanYuan 6 Cylinder Diesel Injector Flow Meter Adaptor Set Common Rail Leak Off Tester Kit Fuel Pressure Set (24 pcs)
https://amzn.eu/d/3NCymiK
 
Last edited:
now have the following coming up
CAN message failure external (ox1E00) ?
DESPITE THE GARAGE FITTING RAIL PRESSURE SENSOR AND WIRING, NOW SHOWING P0191 as a fault
Hi,

I don't understand does they done something since you had replaced the High Presure Pump ?

P0191 is related to the fuel pressure sensor.
 
Last edited:
no they replaced most, but kept putting off replacing the pump for nearly 2 months, excuse after excuse, so they got it runnuing , just , so i could get it the 300yards home,
 
Now does it starts ?

When was the last time, it has started ?

It's a very basic common rail diesel injection engine, how it's possible a garage can't get it working.

Does the car doesn't want to start before of after hp pump replacement ?
 
Last edited:
It was in the garage for not starting, they diagnosed low pressure pump, fuel sensor, and then they got it running in a fashion, diagnosed the HP pump, which they obviously didnt want to do, due to excuse after excuse, so i paid up, they had it running, lots of white smoke, got it home, replaced theHP pump, reconditioned one, went to start, made all the right whirring noises, turned over, but would not fire up, battery fine, fuel pressure fine,
just getting the 2 codes now
rail pressure sensor, new one fitted with wiring by garage, but ordered new to replace
P1643 CAN MESSAGE FAILURE EXTERNAL(0X1E00)
 
So it doesn’t start after you replaced the hp pump ? So the hp pump is certaintly faulty.

Do you still have the original HP pump ?
The recon pump can be an untested used pump branded as a recon one.

For the codes, clean the connector hp pump, and fuel rail presure, erase and try again.

If you disconnect something it will throw you a code, at the moment the key is turned.
 
Last edited:
GOT THE BEAST RUNNING, after 3 new fuel rail sensors, that was the problem !!!
but now its running have noisy low pressure pump in wheel arch, this is supposedly a new one
 
Hi,

You now have the lovely agricutural sound from the bmw engine ;)

New fuel rail presure cost a lot, and need new wires.

Cheap low presure pumps are noisy and don’t last … certainly the one was not that faulty.

I have a new low presure pump from bosch in it box just in case.
 
Last edited:
Back
Top