Who turned out the lights

This site contains affiliate links for which LandyZone may be compensated if you make a purchase.

gymmaniac

Well-Known Member
Posts
621
Location
Bedfordshire
Hi Guys,

At least the clocks changed before my sudden lighting challenge.

'98 300tdi 110.

Both sides the same.

Ignition off:
Full beam flash works

Ignition on:
Side lights don't work
Dipped doesn't work
Full beam doesn't work
Full beam flash works

Fuses all appear ok.
Checked the side/dipped switch and it doesn't look like any power is getting to the switch.

I can't match my wiring to the Haynes manual and can't see where to check next.

Any suggestions?

Cheers
 
This is a simple process of elimination.

1. power o/p from fuses [if not, check feed 12v and fuses]
2. check for power i/p to switches = wiring good
3. isolate lights from switches, check continuity or 12v o/p across switch = switch good
4. re-connect each lighting load and check until there's a fail.
5. check primary earths.

You'll need a DVM for 12v, continuity and resistance for thorough fault finding.
 
This sounds a little bit like the symptoms when the switch fails. As the full headlamp current passes through the switch the plastic gets soft and after a while the contacts no longer make contact. I've had this happen a couple of times.

Of course, do your own checks as per @v8250 's post above, but I wouldn 't be surprised if that's what it is.

Some people who're a bit handy with auto electrics modify the wiring so that the column switch merely switches a relay (or maybe two, one for each light) and the relay carries the full headlamp current. Thus the switch might last a bit longer, and the headlights can be wired with heavier cable and a more direct route, so might be brighter.
 
This sounds a little bit like the symptoms when the switch fails. As the full headlamp current passes through the switch the plastic gets soft and after a while the contacts no longer make contact. I've had this happen a couple of times.
That was my first through as well. If that is the case you can build up the switch contacts with solder so they make contact again as a temporary fix while you wait for the new part to arrive.
 
<snip>
Some people who're a bit handy with auto electrics modify the wiring so that the column switch merely switches a relay (or maybe two, one for each light) and the relay carries the full headlamp current. Thus the switch might last a bit longer, and the headlights can be wired with heavier cable and a more direct route, so might be brighter.

Why "might" the switch last 'a bit' longer and why "might" the lamps be brighter ?
Do you not think that the switch "will" last 'a lot' longer and the lamps "will" be brighter ?
 
Why "might" the switch last 'a bit' longer and why "might" the lamps be brighter ?
Do you not think that the switch "will" last 'a lot' longer and the lamps "will" be brighter ?
Well, your mileage may vary. I'm sure that there are switches who have been mollycoddled with the mere 70 milliamps needed to throw the relay, yet have failed in a few weeks, and lights wired with 35 square millimetre meter tail cable that still refuse to glow at any more than a crepuscular yellow. I don't like offering too many hostages to fortune in the Land Rover world!
 
Here's brief write up on how to fit some 'relays' which will reduce the current (amps) running through the switch and by offering a lower resistance provide more amps (current) to the headlights which will glow brighter, although to be fair, you may need a meter to tell the difference.
The reduction in the amperage passing through the switch will not generate enough heat to soften the plastic, removing this 'failure' point.

 
Cheers guys, much appreciated. As much as I love chasing wiring problems I'm heading straight for a new switch and hoping for an easy weekend.
(DVM on charge just in case...)
 
@gymmaniac , it's really worth fitting relays to the lighting ccts and it's very easy to do. But do not buy the pre-made Boomslang kits as they're a pile of junk [carp wiring/connectors/quality].
 
@gymmaniac , it's really worth fitting relays to the lighting ccts and it's very easy to do. But do not buy the pre-made Boomslang kits as they're a pile of junk [carp wiring/connectors/quality].
Cannot agree more with the above! I bought the boomslang kit and was very unimpressed. I then Set about modifying it to run direct from the battery and for the relays to be in a sensible position and then gave up and stripped it for parts. With what I paid to half modify it I could have custom built the whole thing in a far better manner and that’s without the cost of the initial purchase. Lesson learned. There are no short cuts. If I want something done right and to my standards I need to do it myself rather than try and take shortcuts and use someone else’s work.
 
Update:

So as expected, by I think everyone, putting a new switch in did bugger all.

I have found a new interesting feature: With the light switch on dipped if I hold the main beam on flash... I can blow both the dipped fuses...

As it's a 300tdi defender commercial from '98 just as the wiring was all swapping over to the TD5 I do find some "differences" between my loom and what the manuals say. Would anyone have a complete picture of what the wiring circuit should look like - I still feel I'm not seeing the whole picture of how this should be wired.

Thanks
 
update:

It wasn't the earth strap.

I didn't have time to get to the root of the problem so had an auto sparky in. Can't say I'm impressed.

All he really did, after much unnecessary stripping down was prove that there was no power to the switch.

Can anyone tell me why the switch +ve would have no power? And why two wires going in further up the loom? I've checked all the functions that should work according to the Haynes manual and nothing else seems to be not working.
1715114339169.jpeg


Not impressed that the cable was just left at the back of the dash without any insulation...

Also not impressed that the solution was to feed the light power via one of the auxiliary connectors behind the dash. Not sure what this part of the harness was originally for:

20240507_210744.jpg


I can't leave it in this state and need to find a better feed - even if I go for the relay option that people have talked about.

Ideas?

Oh, and what do you think I paid for the privilege of having my wiring butchered?
 
try
 

Attachments

  • EXTERNAL LIGHTING - defender 300 tdi.png
    EXTERNAL LIGHTING - defender 300 tdi.png
    303.3 KB · Views: 40
  • EXTERNAL LIGHTING - defender 300 tdi test points.png
    EXTERNAL LIGHTING - defender 300 tdi test points.png
    328.5 KB · Views: 34
  • 1999 DEFENDER LIGHTING.png
    1999 DEFENDER LIGHTING.png
    222.3 KB · Views: 38
update:

It wasn't the earth strap.

I didn't have time to get to the root of the problem so had an auto sparky in. Can't say I'm impressed.

All he really did, after much unnecessary stripping down was prove that there was no power to the switch.

Can anyone tell me why the switch +ve would have no power? And why two wires going in further up the loom? I've checked all the functions that should work according to the Haynes manual and nothing else seems to be not working.
View attachment 316659

Not impressed that the cable was just left at the back of the dash without any insulation...

Also not impressed that the solution was to feed the light power via one of the auxiliary connectors behind the dash. Not sure what this part of the harness was originally for:

View attachment 316663

I can't leave it in this state and need to find a better feed - even if I go for the relay option that people have talked about.

Ideas?

Oh, and what do you think I paid for the privilege of having my wiring butchered?
Purple is live for the door interior light switch.
Think it’s live without the ignition on.
Check????
 
Not sure why you're struggling on this. Do you understand automotive electrics?

This is very straight forward, if no 12v to switch input it's either 1. No 12v to fuse, 2. The fuse, 3. The power cable from fuse to switch. Have you tested for 12v between fuse and 12v cable to switch with the switch cable disconnected, and then worked your way back til you get 12v? If not, do this and come back.

Ps. Be sure never to use that ham fisted auto sparky bod again, he's made a right old mess + trust you refused to pay him.
 
Not sure why you're struggling on this. Do you understand automotive electrics?

This is very straight forward, if no 12v to switch input it's either 1. No 12v to fuse, 2. The fuse, 3. The power cable from fuse to switch. Have you tested for 12v between fuse and 12v cable to switch with the switch cable disconnected, and then worked your way back til you get 12v? If not, do this and come back.

Ps. Be sure never to use that ham fisted auto sparky bod again, he's made a right old mess + trust you refused to pay him.
He's given me the confidence I can do a better job!
 
Back
Top